English CS2D Crashes on Linux

10 replies
Goto Page
To the start Previous 1 Next To the start
18.01.23 02:38:02 pm
Up
komasio
User
Offline Off
(not a promo, only a explication video to my problem. https://youtu.be/3FvbGzJeizs )

Hi, I'm back to playing CS2D after a while and I have now Linux Ubuntu 22.04 but whenever I go to play the game it crashes immediately for no reason.
How to fix that?
hi
18.01.23 03:41:57 pm
Up
mrc
User
Offline Off
try the standalone version
IMG:https://cdn.discordapp.com/attachments/1048445028361584671/1064255558372302979/cs2dbr.png
18.01.23 06:17:15 pm
Up
DC
Admin
Offline Off
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
18.01.23 09:12:19 pm
Up
MaksDragon
User
Offline Off
user komasio has written:
(not a promo, only a explication video to my problem. https://youtu.be/3FvbGzJeizs )

Hi, I'm back to playing CS2D after a while and I have now Linux Ubuntu 22.04 but whenever I go to play the game it crashes immediately for no reason.
How to fix that?

I have linux too and no problem. Try to use proton. I use proton-GE 7.43 and all is good
IMG:https://www.gs4u.net/en/350x20/s/242021.png
18.01.23 09:50:58 pm
Up
komasio
User
Offline Off

I tried to install everything I need but it gives me this error
khalid@khalid-HP-Compaq-Pro-6305-SFF:~$ sudo apt-get install libc6:i386 libgtk2.0-0:i386 libidn11:i386 libglu1-mesa:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libpangox-1.0-0:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package libidn11:i386

E: Package 'libpangox-1.0-0:i386' has no installation candidate
khalid@khalid-HP-Compaq-Pro-6305-SFF:~$
what is that

user MaksDragon has written:
user komasio has written:
(not a promo, only a explication video to my problem. https://youtu.be/3FvbGzJeizs )

Hi, I'm back to playing CS2D after a while and I have now Linux Ubuntu 22.04 but whenever I go to play the game it crashes immediately for no reason.
How to fix that?

I have linux too and no problem. Try to use proton. I use proton-GE 7.43 and all is good

I used Proton but still no clue
hi
18.01.23 11:19:17 pm
Up
MaksDragon
User
Offline Off
@user komasio: do you try different version or default version?
IMG:https://www.gs4u.net/en/350x20/s/242021.png
19.01.23 08:17:24 pm
Up
DC
Admin
Offline Off
Unfortunately I have no Linux at hands to test this. It's possible that the lib is not available anymore. Maybe there's some kind of replacement or simply another (newer) version.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
23.01.23 07:12:48 pm
Up
cs2d_is_a_Gem
User
Offline Off
sudo iptables -A INPUT -p udp -m length --length 0:28 -j DROP
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
edited 2×, last 23.01.23 07:48:47 pm
25.01.23 07:33:41 am
Up
MikuAuahDark
User
Offline Off
Starting from Ubuntu 19.10, 32-bit libraries are no longer available except for some select libraries. This means you can't get the i386 dependency, which means CS2D no longer runs in there.

user DC should really compile CS2D for 64-bit if he want to continue having the game playable to be honest. If BlitzMax is limiting 64-bit support then that's unfortunate.
edited 1×, last 25.01.23 07:49:28 am
file cs2d LuaJIT for Dedicated Server (13) JIT POWER! | Know your Lua errors! | Part of LÖVE development team since 11.3
25.01.23 07:19:42 pm
Up
DC
Admin
Offline Off
Yep, can't do that. Unfortunately BlitzMax is 32 bit only.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
26.01.23 06:45:09 am
Up
MikuAuahDark
User
Offline Off
I wonder if CS2D can use https://blitzmax.org/downloads/? It says it also supports Apple M1 too, but not sure if it's same BlitzMax though.
edited 1×, last 26.01.23 01:11:41 pm
file cs2d LuaJIT for Dedicated Server (13) JIT POWER! | Know your Lua errors! | Part of LÖVE development team since 11.3
To the start Previous 1 Next To the start